Structure Cloud is unavailable
Incident Report for Structure Cloud
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 08:45 UTC
Update
We are continuing to investigate this issue.
Posted Mar 19, 2024 - 08:30 UTC
Investigating
The team is working on identifying the root cause. We will provide more details within the next hour.
Posted Mar 19, 2024 - 08:00 UTC
This incident affected: Structure.