Pages may be slow loading
Incident Report for Structure Cloud
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 15:47 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2024 - 14:54 UTC
Investigating
The site is currently experiencing a higher than normal amount of load, which may be causing pages to be slow or unresponsive. We will provide more details within the next hour.
Posted Apr 10, 2024 - 14:41 UTC
This incident affected: Structure and Gantt.